Red and Black

陈小盈 2022-05-31

Red and Black

Time Limit: 1000MS

Memory Limit: 30000K

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@…
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domestic

java

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
// package com.ccying.oj.poj;

import java.util.Scanner;

/**
* <h2>Red and Black.</h2>
*
* @author ccying
* @since 2022/5/31
*/
public class Mian {
// 四个方位
private final static int[][] dirs = {{-1, 0}, {1, 0}, {0, -1}, {0, 1}};
// 地图
private static char[][] grids;
// 是否被访问
private static int[][] isVisit;

private static void init(int row, int clo) {
grids = new char[row][clo];
isVisit = new int[row][clo];
for (int i = 0; i < row; i++) {
for (int j = 0; j < clo; j++) {
isVisit[i][j] = 0;
}
}
}

public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
while (cin.hasNext()) {
// 输入
int w = cin.nextInt();
int h = cin.nextInt();
if (w == 0 && h == 0) {
break;
}
cin.nextLine(); // 去除换行符
init(h, w);
int x = 0; // '@'行坐标
int y = 0; // '@'列坐标
for (int i = 0; i < h; i++) {
String inputStr = cin.nextLine();
for (int j = 0; j < w; j++) {
grids[i][j] = inputStr.charAt(j);
if (grids[i][j] == '@') {
x = i;
y = j;
}
}
}

// dfs
int count = dfs(x, y);

// 输出
System.out.println(count);
}
}

private static int dfs(int x, int y) {
isVisit[x][y] = 1;
int count = 1;
for (int i = 0; i < 4; i++){
int xx = x + dirs[i][0];
int yy = y + dirs[i][1];
if (xx < 0 || yy < 0 || xx >= grids.length || yy >= grids[0].length) { // 非法出界
continue;
}
if (grids[xx][yy] == '.' && isVisit[xx][yy] == 0) {
count += dfs(xx, yy);
}
}
return count;
}
}