HDU 1001

陈小盈 2022-07-22

Sum Problem

Time Limit: 1000/500 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100

###Sample Output

1

5050

Author

DOOM III

Java

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
//package com.ccying.oj.hdu;

import java.util.Scanner;

/**
* <h2>Sum Problem.</h2>
*
* @author ccying
* @since 2022/7/20
*/
public class Main{
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
while (cin.hasNext()) {
long n = cin.nextLong();
long a1 = 1L;
long sum = n * (a1 + n) / 2; // 等差数列求和
System.out.println(sum);
System.out.println();
}
}
}